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MolBook UNIPI is a user-friendly software that allows medicinal chemists to create and manage customized 

molecular databases, import molecules based on their CAS number, calculate multiple properties and share 

data with other users in a simple and intuitive way. 

ABOUT PROJECT 

How to create a new project 
You can create a new project using one of the following alternatives: 

• From the File menu, choose New Project  
• Press CTRL + N 
• Click on the icon from the toolbar  

In all three cases, the “Dialog” window will appear: insert the name of your new project and press the “OK” 

button. 

How to load an existing project 
You can load a previously created project using one of the following alternatives: 

• From the File menu, choose Load Project 
• Press CTRL + L 
• Click on the icon from the toolbar  

In all three cases, the “Open Project” dialog window will appear: search for and select the folder containing 

the project you want to load. 

How to load a recently modified project 
You can recover a recent project by clicking  Recent Projects from the File menu and selecting the desired 

project. 

How to save a project 
You can save your project using one of the following alternatives: 

• From the File menu, choose Save Project as… 
• Press CTRL + S 
• Click on the icon from the toolbar  

In all three cases, the “Save As” dialog window will appear: write the name of your project and press the “Save” 

button. 

How to close a project 
You can close your project using one the following alternatives: 

• From the File menu, choose Close Project 
• Press CTRL + C 
• Click on the icon from the toolbar  

In all three cases, if you have made unsaved changes, the warning window will appear and ask you to choose 

whether to continue or cancel the operation. 

 

 

ABOUT DATABASE 

How to import a database into a project   
Chemical databases can be imported in MolBook UNIPI as CSV file (*.csv), Excel file (*.xlsx), SDF file (*.sdf). 

Both CSV and Excel files must contain at least two columns: one with compounds ID and one with SMILES.  
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This an example of a correct format of Excel file. You can find an example file in the MolBook UNIPI folder (“Example_import.xlsx”). 

 

Before importing a database, you need to open/create a project. You can import a database into an existing 

project using one of the following alternatives: 

• From the Database menu, choose Import  

• Press CTRL + I 

In both cases, an “Import” dialog window will appear: search for and select the database file you want to load. 

A new “Dialog” window will then appear to set the ID codes and SMILES notation of the database molecules 

within the file:  

a) In case of a CSV file, you have to select the CSV delimiter, which separates the different data fields within 

the file (if you do not know it, you can open the CSV file with a standard file editing program). 

b) Select the field associated with the ID of the molecules from the corresponding drop-down menu and then 

press the   button, which will be coloured green. If you want to undo this selection, press the 

button next to it.  

c) Select the field associated with the SMILES code of the molecules from the corresponding drop-down menu 

and then press the   button, which will be coloured green. If you want to undo this selection, press the 

button next to it.  

d) press the “OK” button. 

The molecules included in the imported file will be loaded in the project. If a database is already present within 

the project, the imported molecules are added to the existing database. 

How to export a database or selected molecules 
You can export the whole database by choosing Export As… from the Database menu. Then, in the “Export 

Database” dialog window, select the destination folder and the desired format among CSV file (*.csv), Excel 

file (*.xlsx) and SDF file (*.sdf).  

You can also export molecules of your database after selecting them in the main window (the corresponding 

row of the table will be highlighted in blue), clicking the right button of the mouse (with the mouse arrow 

positioned in one of the rows of the selected molecules) and selecting the “Export selected” option in the 

context menu. The “Export database” dialog window will appear. Then, select the destination folder and the 

desired formats among CSV file (*.csv), Excel file (*.xlsx) and SDF file (*.sdf). 

How to add a molecule to an empty/existing project 
You can add a molecule into an empty project or into a project that already contains a database of molecules. 

To do this operation you can use one of the following alternatives: 

• From the Edit menu, choose Add Molecule 

• Press CTRL + A 

• Click on the icon from the toolbar  
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n all three cases, the “Add/Edit Molecule” dialog window will appear. You need to write the ID of the molecule 

and the structure in SMILES format within the corresponding boxes. If you don’t have the SMILES code of your 

molecule, you can draw the 2D structure of the molecule by using the structure editor: the corresponding 

SMILES code will automatically appear on the corresponding box.  

Clicking on the “Add/Edit Properties” button: a new dialog window, in which you can associate properties to 

the new molecule, will appear. Now you can add a new property using the corresponding box. In both cases 

you need to write the property value in the corresponding box and press the “Add” button. The property with 

the corresponding value will appear in the blank area. For editing the value of a property, you can double click 

on the value to be changed. Then, clicking on the “OK” button of the “Add/Edit Properties” dialog window, the 

new property will be added to the “Add/Edit Molecule” dialog window. Add the new molecule by clicking “OK” 

button of the “Add/Edit Molecule” dialog window. 

How to edit a molecule  
You can edit a molecule, after selecting it in the main window (the corresponding row of the table will be 

highlighted in blue), by using one of the following alternatives: 

• From the Edit menu, choose Edit Molecule  

• Press CTRL + E 

• Click on the icon from the toolbar  

• Click the right button of the mouse (with the mouse arrow positioned in the row of the selected 

molecule) and then select “Edit selected” on the context menu.  

In all four cases, the “Add/Edit Molecule” dialog window, will appear. You can modify the ID of the molecule 

and/or the structure in SMILES format. If you do not have the new SMILES code of your molecule, you can 

modify the 2D structure of the molecule within the structure editor and the SMILES code will be automatically 

modified. Clicking on the “Add/Edit Properties” button a new dialog window will appear, in which you can 

either select a property that is already included in your database or add a new property. If you want to change 

an existing value, you must double click with the left button of the mouse in the corresponding cell, then write 

the new value and press Enter. 

How to delete a molecule  
You can delete a molecule, after selecting it in the main window (the corresponding row of the table will be 

highlighted in blue), by using one of the following alternatives: 

• From the Edit menu, choose Delete Molecule 
• Press CTRL + D 
• Click on the icon from the toolbar  
• Click the right button of the mouse (with the mouse arrow positioned in the row of the selected 

molecule) and then select “Delete selected” on the context menu. 

 

In all four cases, the “Delete confirmation” dialog window will appear. By clicking on the “Yes” button the 

molecule will be removed from the database. If you select multiple molecules before doing one of the four 

operations, you can delete them all at once.  

How to import molecules based on their CAS number 

MolBook UNIPI allows you to import molecules into your project based on their CAS number. Choose Import 
from CAS number from the Database menu. The “CAS importer” dialog window will appear. You can then write 
the proper CAS numbers in the search box or upload a text (*.txt) file containing a list of CAS numbers, by using 
the “Upload” button. In both cases, press the “OK” button to add them to your database.  
Remember to check your internet connection before doing this operation.  
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ABOUT PROPERTIES 

How to calculate and show properties 
MolBook UNIPI can calculate and show four different properties: 1) Molecular Weight, 2) Chemical Formula, 

3) Number of Heavy Atoms and 4) Predicted LogP. To compute them, choose Computed Properties from the 

Database menu and select the desired properties. 

How to show/hide properties 
MolBook UNIPI allows you to display either all or only some of the properties available in a database. You can 

show/hide properties by using two alternatives: 

• From the Database menu, choose Show/Hide Properties  

• Click on the    icon from the toolbar  

The “Show/Hide Properties” dialog window will appear. The left column lists all available properties of the 

database, whereas the right column lists only the currently displayed ones. You can either show or hide all 

properties at the same time by using the “Show all” and “Hide all” buttons, respectively. You can add properties 

to be displayed by selecting them in the left column and using the “Show” button; you can remove properties 

to be displayed by selecting them in the right column and using the “Hide” button. At the end of your setup 

press the “OK” button of the dialog window to allow the new visualization. Be aware that the "ID" and "SMILES" 

properties must always be shown. 

How to delete/restore properties 
You can delete/restore properties by choosing Delete Properties from the Database menu. The “Delete 

Properties” dialog window will appear. The left column lists all available properties of the database, whereas 

the right column lists the properties to be deleted. You can choose properties to be deleted by selecting them 

in the left column and using the “Delete” button; you can choose properties to be restored by selecting them 

in the right column and using the “Restore” button. At the end of your setup press the “OK” button of the 

dialog window to finalize the operations. 

How to add/open/remove an attachment 
MolBook UNIPI allows you to add one or more attachments to a molecule such as images (*.png, *.jpg, *.jpeg), 

text (*.txt) or PDF (*.pdf) files. You can add attachments by selecting the molecules in the main table, clicking 

the right button of the mouse (with the mouse arrow positioned in the row of the selected molecule) and then 

selecting “Chemical Notebook” in the context menu. The “Chemical Notebook” dialog window will appear. You 

can click on the “Add” button and select the desired file in the “Load Attachment” dialog window.  

You can also open and remove an attachment from the “Chemical Notebook” dialog window, by selecting the 

desired file in the window box and clicking on “Open” or “Remove” buttons, respectively.  

 

ABOUT QUERY 

How to perform a structural search 
MolBook UNIPI allows you to search for specific database molecules based on either similarity or 

substructure/superstructure relation with respect to a query structure. You can create a structural query by 

using one of the following alternatives: 

• From the Database menu,  choose Query and then select Structural Query 

• Click on the    icon from the toolbar  

In both cases, the “Query Structure” dialog window will appear. You need to write the structure of your query 

in SMILES format. If you do not have the SMILES code of your query, you can use the structure editor by 

drawing the 2D structure of the query: the corresponding SMILES code will be automatically added. If you want 

to apply a similarity filter, select the “Similarity” option and choose the appropriate similarity threshold using 

the corresponding sliding bar. Alternatively, you can select molecules that either contain the query or are 
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contained within it, by selecting the “Substructure” or “Superstructure” options, respectively. By clicking the 

“OK” button, a new database containing only those molecules that fulfill the selected criteria will be loaded. 

How to perform a single/multiple property search 
MolBook UNIPI allows you to search for specific database molecules based on properties values.  You can 

create a property query by using one of the following alternatives: 

• From the Database menu, choose Query and then select Property Query 

• Click on the    icon from the toolbar  

In both cases, the “Query Properties” dialog window will appear. You can select a property (among those 

available in the database) and an operator (among =, >, >=, <, <=, contains) from the corresponding drop-down 

menus, and add a threshold value in the adjacent blank box. Then, by clicking on the “Add” button the filter 

will be added and shown in the table. You can now add another filter by repeating the previous steps or remove 

one of the added filters by selecting it from the box an clicking on the “Remove Filter” button. To apply the 

added filters, click on the “OK” button: a new database containing only those molecules that fulfill the selected 

filters will be loaded. 

 

ABOUT VISUALITAZION  

How to display molecules in grid view mode 
You can visualize either all or a set of molecules in a grid view mode by first selecting the molecules of interest 

in the main window and then using one of the following alternatives:  

• From the Database menu,  choose Grid View 

• Click on the    icon from the toolbar  

In both cases, the “Grid View” panel will appear. The panel will show the structures of the selected molecules 

of the database, together with the corresponding IDs, in a grid style. If you want to display all molecule in grid 

view mode, you can select them all at once by clicking with the right button of the mouse on any molecule’s 

row in the main window and selecting “Select All” in the context menu. 

How to change the layout of database 
You can change the layout of database (Classic or Table Image) according to your preferences by using one of 

the following options: 

• From the Settings menu choose View Mode and then select either Classic or Table Image 

• Click on the    icon from the toolbar  

  

How to change the size of the displayed structures 
You can change the size of the 2D structure displayed for each molecule in both Classic and Table Image layouts 

by the changing the layout resolution. From the Settings menu, choose Resolution and then select the desired 

option among Low, Medium and High. The “Resolution changed” dialog window will appear, informing that 

the new settings will be available after the closing and reopening the projects. The higher the resolution 

chosen, the bigger the size of the displayed images.  

How to highlight molecules in a database 
If you want to highlight the rows of selected molecules of the database, you first need to select the molecules 

in the main table (the selected rows of the table will be highlighted in blue), then click with the right button of 

the mouse (with the mouse arrow positioned in one of the rows of the selected molecules), select “Highlight” 

in the context menu and then choose the desired colour among “Green”, “Yellow” and “Red”. 
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If you want to remove the colour on some table rows, select the coloured rows (the selected rows of the table 

will be highlighted in blue) and click with the right button of the mouse (with the mouse arrow positioned in 

one of the rows of the selected molecules), select “Highlight” in the context menu and then choose “Clear”. 

 

ABOUT TOXICITY PREDICTIONS  
Molbook UNIPI allows to predict the potential mutagenic, hepatotoxic, carcinogenic and estrogenic effect of 

one or multiple molecules by employing machine learning models belonging from VenomPred platform. For 

more details visit http://www.mmvsl.it/wp/venompred/ . 

After selecting the molecules for which the toxicity predictions should be performed, you can use one of the 

following options: 

• From the Toxicity menu, choose Predictions 

• Click on the    icon from the toolbar  

 

In both cases, the “VenomPred” dialog window will appear. You can select the endpoints you want predict 

among “Mutagenicity”, “Hepatotoxicity”, “Carcinogenicity” and “Estrogenicity” for the selected molecules. 

After clicking the “OK” button, the predictions results will be available in the table in form of properties (new 

columns will be added). VenomPred will provide a percentage “Probability” value, ranging from 0 to 100, 

related to each toxicity prediction requested. Predictions above or equal to 50 correspond to potential toxicity.  

 

ABOUT DATA SHARING  
If you share and synchronize a MolBook UNIPI project folder with other users through file storage, sharing and 
synchronization services, such as Google Drive, Dropbox, One Drive and iCloud Drive, all users to whom access 
and editing rights are provided will be able to read and modify the database. Any change applied to the 
database will be then viewed by all other users. This way, the same database can be either only examined or 
fully handled by multiple people (depending on the shared rights), thus facilitating information exchange 
among research collaborators and allowing them to update the database with new compounds and/or 
properties. 
If a project folder is opened simultaneously by multiple users, a warning window will appear to ask you whether 
the database should be accessed in “READ ONLY mode” or in “WRITE mode”. If you select “WRITE mode”, you 
need to be aware that either your changes or the other users’ ones may not be saved.  
Be aware that to enable project sharing and synchronization, all users need to have MolBook UNIPI properly 
installed in their own device. Moreover, the shared MolBook UNIPI project needs to be physically stored in 
each user’s device, so that it can be loaded and modified through MolBook UNIPI.  

 

 

         
        Enjoy MolBook UNIPI!  
 
      MolBook UNIPI is free for licenced academic use. 
          For any information contact molbook@mmvsl.it .  
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